The app on Android requires any device running Android 4.4 or newer.

On iPhone/iPad you need to be running at least iOS11.